SimCity (US-Ntsc/FR-Pal)

Page 4 of 4 Previous  1, 2, 3, 4

Go down

20180122

Post 

SimCity (US-Ntsc/FR-Pal) - Page 4 Empty SimCity (US-Ntsc/FR-Pal)






PepilloPEV Patch v2.0 for US-NTSC, FR-PAL:
Code:
https://www.dropbox.com/sh/5flu2bljurqpqdc/AABzmMYGM1mUn3vl9v3JNzbZa?dl=0

Shiryu PCM Sets:
#011 - SimCity: Chiptune Administration
SimCity (US-Ntsc/FR-Pal) - Page 4 MSU1-011-SimCity-ChiptuneAdministration
[ GAMEPLAY ][ DOWNLOAD ]

#012 - SimCity: Orchestral Administration
SimCity (US-Ntsc/FR-Pal) - Page 4 MSU1-012-SimCity-OrchestralAdministration
[ GAMEPLAY ][ DOWNLOAD ]

#013 - SimCity: Synthetic Administration
SimCity (US-Ntsc/FR-Pal) - Page 4 MSU1-013-SimCity-SyntheticAdministration
[ GAMEPLAY ][ DOWNLOAD ]

FullGameZone/CarFlightGames PCM set:
https://app.box.com/s/fsxoe0l4uptskhv9ubzslqxj97846ffc


Last edited by pepillopev on Wed 21 Aug 2019 - 13:26; edited 19 times in total
avatar
pepillopev

SimCity (US-Ntsc/FR-Pal) - Page 4 Image211

Since : 2017-10-16

Back to top Go down

Share this post on: diggdeliciousredditstumbleuponslashdotyahoogooglelive

SimCity (US-Ntsc/FR-Pal) :: Comments

avatar

Post on Sun 30 Dec 2018 - 8:56 by stevefox1620

Thank you for your awesome work! The videos tell me "unavailable" I checked out all three. Orchestrated is awesome. Synthetic is cool too but it has some major sound issues. The intro doesn't play and when you sit there hammer bulldoze on nothing for example, you get really bad sound distortion.

Back to top Go down

avatar

Post on Sun 30 Dec 2018 - 9:56 by Shiryu

Ah yes, the videos will be live at 00:00! Very Happy
I just dropped them here as a head start for you guys.
Yes, Synthetic sound is very fat and despit emy best equalizing efforts most of the sounds is saturated. thanks for the tip about th ePCM intro, I beleive a last minute update on track broke the PCM compatibility so i will get to fixing that ASAP. Oh, regarding emulation I only get sound clicks and pops on snes9x (in fact,those are in the video I made) but those will not happen in real hardware or a working version of bsnes/higan.

Back to top Go down

avatar

Post on Sun 30 Dec 2018 - 10:29 by Shiryu

Back to top Go down

avatar

Post on Sun 30 Dec 2018 - 16:44 by pepillopev

@Shiryu Ok, posted to the top (includes the correct Synthetic Administration link for the DOWNLOAD). Thanks for your contribution.

Back to top Go down

avatar

Post on Mon 31 Dec 2018 - 0:29 by Shiryu

Sweet! Have a good one folks!

Back to top Go down

Tropylium

Post on Mon 31 Dec 2018 - 12:13 by Tropylium

Nice, thanks for updating. Your Synthetic Admin gameplay link still goes to the same video as Orchestral Admin though…

(and, beside the point I know, but I'm kinda fighting the urge to point out the obvious city construction problems in the example videos)

Back to top Go down

avatar

Post on Mon 31 Dec 2018 - 12:26 by Shiryu

Thanks, fixing that link pronto.

Back to top Go down

avatar

Post on Tue 20 Aug 2019 - 18:07 by fullgamezone

This patch causes the game to crash using the SD2SNES cartridge.

Back to top Go down

avatar

Post on Wed 21 Aug 2019 - 2:37 by pepillopev

fullgamezone wrote:This patch causes the game to crash using the SD2SNES cartridge.
@fullgamezone Ok, I did a brief test on my sd2snesPro using both BPS and IPS patches and had no crashing issues (using the version 2.0 patch, not 1.3). Version 1.3 is pretty much deprecated and no longer supported by me.

I let the game run to the title screen and started a quick practice run with no crashing. I used the following ROM:

Sim City (NTSC-US) with CRC 8AEDD3A1 [must be non-header]

Do not use the patch named "scityf-msu1-v2.0". That is meant for the French PAL version of the game.

If you are still crashing, I will need to know more about how this crash occurs or when it occurs to be of any help to you. A video would be helpful.

I no longer have my original sd2snes to test with. I gave that one away.

UPDATE: I removed the 1.3 patches and references from the zip archive to avoid any confusion in the future from others.

Last edited by pepillopev on Wed 21 Aug 2019 - 13:20; edited 1 time in total

Back to top Go down

avatar

Post on Wed 21 Aug 2019 - 12:03 by fullgamezone

I'll try again
thanks

Back to top Go down

avatar

Post on Thu 22 Aug 2019 - 7:19 by fullgamezone

I tested it, it worked but the save game failed. you save the game and will play another day save was not the last time you saved

Back to top Go down

avatar

Post on Thu 22 Aug 2019 - 7:39 by pepillopev

@fullgamezone Have you tried holding the RESET button until you go back to the sd2snes main menu to save? I recall with sd2snes this has to be done if MSU-1 is involved. MSU-1 requires full access to the SD card and only way to properly save to battery backed up RAM (via SRM file on SD card) is to do this step. Try this after deleting the previous save.

Back to top Go down

avatar

Post on Thu 22 Aug 2019 - 7:54 by fullgamezone

Firmware 1.13

Back to top Go down

avatar

Post on Thu 22 Aug 2019 - 8:01 by pepillopev

fullgamezone wrote:Firmware 1.13
As stated before, both sd2snes and sd2snesPro require holding reset button briefly then release to go back to main sd2snes menu to save SRM files to SD card when using MSU-1. Regardless of firmware version.

Back to top Go down

avatar

Post on Thu 22 Aug 2019 - 8:12 by pepillopev

@fullgamezone Yup, I just verified it on my sd2snesPro (it is the same for regular sd2snes too). For only msu-1 games, if you just save and power down your SNES, your game will not save. If you already have a SRM save on your SD card for this game, the SRM save will remain un-touched if you do not hold the RESET button for 1-2sec then release. The sd2snes menu must come back, then your game will be saved.

This has nothing to do with the patch but a hardware limitation of the current implementation of the sd2snes hardware (original and pro version). MSU-1 requires full control of the SD card reader, thus, negating real time SRAM saves to the card. Only way is to hold RESET down for a bit then release to properly save. Only non-msu1 games have real time saves.

This was briefly discussed at this topic:
https://www.zeldix.net/t1860-sd2snes-pro-announced

I recall Ikari and Conn having a discussion about this more in detail in another topic which I cannot find here on Zeldix. Maybe Conn remembers that topic.

Back to top Go down

Conn

Post on Thu 22 Aug 2019 - 9:46 by Conn

This was discussed in the earthbound thread:
https://www.zeldix.net/t1931-earthbound-msu-1

Back to top Go down

avatar

Post on Thu 22 Aug 2019 - 10:05 by pepillopev

Conn wrote:This was discussed in the earthbound thread:
https://www.zeldix.net/t1931-earthbound-msu-1
@Conn Thank you for following up. Smile

Back to top Go down

avatar

Post on Sat 24 Aug 2019 - 10:48 by fullgamezone

Okay, I got it now. But the game continues with instability, when you enter the VOICE option which is where city dwellers talk about problems the game tends to crash. Sometimes it will crash, and sometimes it won't crash. The save worked by resetting before shutting down.

Thank you

Back to top Go down

avatar

Post on Sat 24 Aug 2019 - 10:56 by pepillopev

@fullgamezone Hmm, the patch is very simple and should not interfere with the game's native code. Unfortunately, all I can do is test on my SuperNT with my sd2nesPro and attempt to replicate the issue. If I cannot, there is nothing more I can do to help.

If the issue can be replicated in software (via Higan/bSnes/Snes9x) then, at least, I have something to work with. Hardware is difficult to debug.

Back to top Go down

avatar

Post on Mon 26 Aug 2019 - 1:53 by pepillopev

@fullgamezone I tested the game on my genuine sd2snesPro with superNT w/o issue. I played for about 30 minutes and randomly went into VOICE w/o crashing. Also tested the other buttons in the game at random times. Saved, powered off, came back up and played for another 30 minutes w/o issue (again, testing VOICE and other buttons).

I will see if my sister will loan me back the genuine sd2snes cart for me to test this game on. For now, my only suggestion are these:

#1 Reformat your SD-card
#2 Copy newly patched SimCity+PCMs
#3 Try a different SD card and repeat steps #1 and #2
#4 Test on a different SNES? (if you have one)

Again, hardware issues are very difficult to debug. If this issue cannot be reproduced on an emulator, then there is little I can do for you. If someone else reports the same issue, then possibly I may consider re-coding this game. If you are the only one reporting this, I am going to suspect a hardware issue on your end (old SNES supplying inadequate voltage to sd2snes, sd2snes clone, etc). Much luck.

Back to top Go down

Conn

Post on Mon 26 Aug 2019 - 10:15 by Conn

I looked into the asm and didn't find anything what can trigger such a bug either. It's very well coded, only small complex stuff could be made easier, e.g., this bunch of code:

Code:

goMsu:
 JSL msuPlay ; track already in A from track table
 LDA $01FA30,X ; load msu loop value from data table
 JSL msuLoop
 PLX
 PLA
 JSL muteSpc
 RTL

muteSpc:
LDA #$00 ; mute value for native code to process
STA $2140
RTL

msuLoop:
 STA $2007
 RTL

 

Can simply be merged to:
Code:

goMsu:
 JSL msuPlay ; track already in A from track table
 LDA $01FA30,X ; load msu loop value from data table
 STA $2007
 PLX
 PLA
 LDA #$00
 RTL
since the return RTL brings you to the store of 00 to 2140 anyways (and the previous can be immediately stored to 2007.

I just bring this up since I was asking myself whether this current double store of 00 to 2140 might be involved in the bug fgz reports, but it shouldn't.
So for now I too assume it must be something on fgz' side.

Back to top Go down

Post  by Sponsored content

Back to top Go down

Page 4 of 4 Previous  1, 2, 3, 4

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum