Top Gear 3000

Page 1 of 2 1, 2  Next

View previous topic View next topic Go down

20171008

Post 

Top Gear 3000






Last edited by kurrono on Thu 12 Oct 2017 - 23:20; edited 3 times in total
avatar
kurrono
Blacksmith
Blacksmith

Since : 2015-03-22

Back to top Go down

Share this post on: Excite BookmarksDiggRedditDel.icio.usGoogleLiveSlashdotNetscapeTechnoratiStumbleUponNewsvineFurlYahooSmarking

Top Gear 3000 :: Comments

avatar

Post on Sun 8 Oct 2017 - 9:22 by Conn

for all missing bsnes compatibilty, I tried hard but completely failed making a xml. If somebody can help, I'd appreciate very much Very Happy

Back to top Go down

avatar

Post on Sun 8 Oct 2017 - 9:34 by kurrono

Qwerty did super mario kart msu1 xml and its working..i even used snespurify to create that.xml ..still dont work

Back to top Go down

avatar

Post on Sun 8 Oct 2017 - 9:40 by Conn

Here's my try so far:

Code:

<?xml version="1.0" encoding="UTF-8"?><cartridge region="NTSC">
   <rom>
      <map mode="linear" address="00-7f:8000-ffff"/>
      <map mode="linear" address="80-ff:8000-ffff"/>
   </rom>
   <necdsp revision="uPD7725" frequency="8000000" program="dsp4.bin" sha256="63EDE17322541C191ED1FDF683872554A0A57306496AFC43C59DE7C01A6E764A">
      <dr mask="004000">
         <map address="30-3f:8000-bfff"/>
         <map address="b0-bf:8000-bfff"/>
      </dr>   
     <sr mask="004000">
        <map address='30-3f:c000-ffff'/>
        <map address='b0-bf:c000-ffff'/>
     </sr>
   </necdsp>
   <msu1>
      <map address="00-3f:2000-2007"/>
      <map address="80-bf:2000-2007"/>
      <mmio>
         <map address="00-3f:2000-2007"/>
         <map address="80-bf:2000-2007"/>
      </mmio>
   </msu1>
</cartridge>

Maybe qwerty or somebody knows what is wrong...

Back to top Go down

avatar

Post on Sun 8 Oct 2017 - 16:08 by PittStone

The Sound from the car is crackling. Is it possible to make the engine sound from the car to half loud? Maybe all the game sfx to half. the music is not really audible at this moment.

Back to top Go down

avatar

Post on Sun 8 Oct 2017 - 16:20 by kurrono

Ill check when i get home hehe..

Back to top Go down

avatar

Post on Sun 8 Oct 2017 - 20:51 by Conn

Watching the video, I must admit the sfx when driving is really a bit loud. The only possibility I see is that Kurrono amplifies the pcm tracks to a higher level - if the pcm:s and sfx are balanced you can control the overall volume much better.

Back to top Go down

avatar

Post on Wed 11 Oct 2017 - 3:11 by kurrono

Ok i uploaded ..the improved pcms. Until smbody. Makes new remixes

Back to top Go down

avatar

Post on Wed 11 Oct 2017 - 20:59 by Conn

With the highly appreciated help from Ikari, I am now able to support bsnes (plus, v73) and higan (all versions?). Please re-download the patch from first post.

In the readme is detailed described the process what you need to do (included also in subfolders required files, like dsp4.bin, dsp4.program.rom, dsp4.data.rom)...

My sincere advise: just use snes9x 1.55 Archery

Back to top Go down

avatar

Post on Thu 12 Oct 2017 - 23:21 by kurrono

Sorry guys i had to change that intro pcm was kinda boring..now youll see just check it out

Back to top Go down

avatar

Post on Mon 16 Oct 2017 - 2:01 by smokemonster

Cool release. Is this hack emulator-only? It's not working on SD2SNES unless I've messed something up on my end.

Back to top Go down

avatar

Post on Mon 16 Oct 2017 - 2:02 by kurrono

Emulator for now..i tested on my sd2snes it stays on black screen...

Back to top Go down

avatar

Post on Mon 16 Oct 2017 - 2:25 by Conn

But we do not know whether it is Kurrono's maybe corrupt sd2snes device. If it doesn't work on other sd2snes as well, I suggest asking Ikari:
https://github.com/devinacker/bsnes-plus/issues/139

Back to top Go down

avatar

Post on Mon 16 Oct 2017 - 2:28 by kurrono

Conn im buying another sd2snes next week..after i get me car..im returning..my leased hyundai sonata..im gettin a mini,cooper.

...oh i guess i send my drs file..you check it ..when u have time..i ve been checking..lot of opcodes and none seem to mute the boss music

Back to top Go down

avatar

Post on Mon 16 Oct 2017 - 5:16 by kurrono

My old sdnes version got corrupt..in version 1.6...and only firmware 1.0 and 1.1 works...ikari told me ..my sdsnes has problem on,the
dma.like the sdcard is the problem..but i dont...know..i,tested lotsbof the sdcards and all fail..latest version of sdnes firmware runs..but when i load rom it stays on black screen..my.solution is gettin other sd2snes for the 200 dollars or.cheapet on ebay for 160

Back to top Go down

avatar

Post on Mon 16 Oct 2017 - 6:31 by Conn

Only thread I found about this is this one:
https://www.dragonbox.de/de/forum/topic/32-sd2snes-top-gear-3000-startet-nicht.html
(German)
It says it should run on firmware 0.1.7

Edit:
Also you need dsp4.bin
Find it in the bsnes subfolder and paste it in the sd card folder where also your patched Rom is located

Edit2:
sorry read more about it, dsp4.bin must be placed in the sd2snes folder

Edit3: added a sd2snes tutorial to the readme of the patch, also updated tg1&3k video, as shiryu finally did it Very Happy

Back to top Go down

avatar

Post on Mon 16 Oct 2017 - 11:50 by smokemonster

I've heard from someone that Top Gear 3000 works on their SD2SNES, but the MSU-1 hack doesn't (crashes to black screen), which means that it must be the hack. I can't test myself until December though.

Back to top Go down

avatar

Post on Mon 16 Oct 2017 - 13:27 by Conn

Strange - as it should work. I admit, I was lazy on this hack, but it should nevertheless work. I informed Ikari.

The only thing differently emulated on sd2snes is this here:
loop:
bit $2000
bvs loop    ; track not ready
(in emulator it doesn't loop, since the track immediately is ready, on sd2snes it does loop here. But I see no reason why it should break the code).

I usually hack this in the nmi with busy flag set to avoid flickering, but in TG 3k all tracks are loaded in black screen

Back to top Go down

avatar

Post on Mon 16 Oct 2017 - 19:06 by ikari_01

It's a memory mapping issue due to the expansion of the ROM to 12 Mbits which I stumbled upon recently, and described here: https://github.com/devinacker/bsnes-plus/issues/139#issuecomment-335842616
And here:
https://sd2snes.de/blog/archives/833#comment-991420

Basically DSPx LoROMs >8Mbits use the DSP at a different address because otherwise the DSP and ROM addresses clash. This doesn't seem to be documented in the official development manuals but is actually implemented in Super Bases Loaded 2 (12Mbit LoROM) which is a DSP1b game.

Emulators have a special case for these larger ROM sizes but usually only apply it to DSP1/1b, ignoring DSP2-4 simply because no commercial ROM existed for them that was >8Mbits LoROM.

In theory the DSP should only be mapped from bank 30 onwards so 12Mbits won't formally result in a conflict. But with Super Bases Loaded 2 using available address decoding logic it was probably too much of a hassle to avoid mirroring of the upper 4Mbits to the full 16Mbits so they moved the DSP out of the way completely, to bank 60-6f:0000-7fff instead of 30-3f:8000-ffff.

Strictly speaking I'd encourage the ROM hackers to adapt the alternative DSP mapping for expanded ROMs (which would mean patching every DSP access in the ROM), and emulator authors to extend their special case to DSP2-4 too.
But seeing that two ROM hacks now exist that already use the overlapping mapping I think I'll just go with that and map the DSP2-4 to 30-3f even with large LoROMs even though it leaves a "hole" in the ROM.

Back to top Go down

avatar

Post on Tue 17 Oct 2017 - 2:30 by Conn

Ah, I see, so the expansion to 1.5 mb cause problems. I do not know how to make it different, couldn't find free Rom space in the native Rom...
But if I understand you correctly you're going to allow expansion in a next firmware, so that this patch works?

Back to top Go down

avatar

Post on Tue 17 Oct 2017 - 2:39 by kurrono

Hey ikari..long time..i was with the problem on the dma on my sd2snes ..we talk like almost 2 yrs ago..im buying a,new sd2snes soon..thanks for ur help in the past,man!!

Back to top Go down

avatar

Post on Wed 18 Oct 2017 - 4:06 by kurrono



Conn I made top gear 3000 works on my sd2snes

Back to top Go down

avatar

Post on Wed 18 Oct 2017 - 4:51 by ikari_01

Nice! How did you do it?

Back to top Go down

avatar

Post on Wed 18 Oct 2017 - 5:03 by Conn

I put the code into an expnded area (20/8000, pc 10/0000). My best guess is that Kurrono simply overwrote some native areas, so that it's not necessary to expand to 1.5MB - risky... but).



Back to top Go down

avatar

Post on Wed 18 Oct 2017 - 5:05 by kurrono

I check on windex..there were. 000000 not FFFFFFF

Back to top Go down

Page 1 of 2 1, 2  Next

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum