The Death and Return of Superman

View previous topic View next topic Go down

Share this post on: Excite BookmarksDiggRedditDel.icio.usGoogleLiveSlashdotNetscapeTechnoratiStumbleUponNewsvineFurlYahooSmarking

The Death and Return of Superman :: Comments

Post on Fri 3 Nov 2017 - 8:09 by Shiryu



I have stumbled upon a weird bug that I am unsure is due to the patch or not. I have cut the video from a point where the sound of the enemies weapons get stuck on a infinite loop, eventually flooding all eight channels so all you can hear is the chainsaw and the digital audio. This happened again but on the first stage with the minigun sounds. Played and recorded with the latest bsnes+. Unsure if it happens with snes9x or higan.

Back to top Go down

avatar

Post on Fri 3 Nov 2017 - 8:36 by Conn

Yes, we also stumbled into this bug. I am not sure what the cause for this is, it could also be a problem with the native rom.
At least it is random and rare... if I knew the trigger, I could try to fix it, but I was unable to find it.

Back to top Go down

Post on Fri 3 Nov 2017 - 8:42 by Shiryu

I too was sadly unable to repeat it at will. Too bad. Crying or Very sad

Back to top Go down

avatar

Post on Fri 3 Nov 2017 - 10:45 by Conn

I think I was able to fix it, redownload the patch from first post, and apply on a FRESH rom.
The malcode executed was a code to accelerate the boss, now you have a lag of a few seconds before you are able to fight him. Nevertheless, if that bug is gone, I take with pleasure the lag in exchange Wink

Edit, moved your video to first post, thanks for this Very Happy

Back to top Go down

avatar

Post on Fri 3 Nov 2017 - 22:50 by kurrono

Hey Conn Crying or Very sad ,so accelerating boss was the problem..oops i guess that was my fault..cause even on not msu music there is timing to the boss theres a pause...thanks for fixing it Crying or Very sad

Back to top Go down

avatar

Post on Sat 4 Nov 2017 - 6:20 by Conn

Very Happy so the patch works now at 100%?

Back to top Go down

avatar

Post on Sat 4 Nov 2017 - 7:39 by kurrono

Looks like it..no more motorcycle noise or chainsaw..it was accboss code....yep...

Back to top Go down

avatar

Post on Sat 4 Nov 2017 - 22:35 by Conn

Alright, I uploaded yet another patch. The disabling of the boss lag caused other bugs, which I had to fix. Kurrono found these obsolete now since we had to re-enable the boss lag - I checked too and it is safe to remove them, so the patch is now clean (redownload from first post).

As said, it was necessary to re-enable the boss lag to avoid the sfx bugs, you now have a waiting time of about 5 seconds at each boss, but this lag is also present in the native version.

Back to top Go down

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum